help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tab-key not working in auctex?


From: Johs
Subject: Re: Tab-key not working in auctex?
Date: Fri, 10 Nov 2006 16:14:43 +0100
User-agent: KNode/0.10.4

Malte Spiess wrote:

> "Johs" <address@hidden> writes:
> 
>> I have installed auctex for emacs in Ubuntu. But when I press the Tab-key
>> nothing happens.
>>
>> I know that multiple whitespaces are treated as one in latex but in my
>> .tex file it is sometimes nice to use Tab-key indentation to make the
>> text easier to read (when writing pseudocode).
> 
> Do you mean that never anything happens when you press TAB or just in
> certain situations nothing happens?
> 
>> How do I make my Tab-key respond i auctex?
> 
> What does it say when you hit "C-h k TAB"? (Display documentation of the
> function invoked by TAB.)

It says:

TAB runs the command indent-for-tab-command
   which is an interactive compiled Lisp function in `indent'.
(indent-for-tab-command &optional PREFIX-ARG)

Indent line in proper way for current major mode or insert a tab.
Depending on `tab-always-indent', either insert a tab or indent.
If initial point was within line's indentation, position after
the indentation.  Else stay at same point in text.
The function actually called to indent is determined by the value of
`indent-line-function'.


but nothing happens when I press the Tab-key. Maybe Tab-key is not meant to
work in auctex.


> Really wonder why it does not work out of the box. Have you tried it in
> any \begin... \end... environment?


Yes and nothing happens there either.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]