[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

utf text console - control-g does not work any longer

From: Peter Petersen
Subject: utf text console - control-g does not work any longer
Date: Wed, 11 May 2005 22:53:44 +0200
User-agent: Gnus/5.1007 (Gnus v5.10.7) Emacs/21.3 (gnu/linux)


I decided to use Gnus in a Linux text console.

The reasons are:
- all the fonts for Emacs and/or XEmacs when under X are either too big
or too small; there are just not enough intermediate font sizes, and my
eyes are very sensitive
- when running Emacs and/or XEmacs in "gnome-terminal" the fonts look
way better and have many more intermediate steps (so font size is no
longer an issue!), but my eyes start to hurt or I get a headache (thanks
to anti-aliasing, I fear - though switching it off is no solution,
because fonts look ugly then in Emacs AND in web browsers!)

Now enough with that, let's get to my problem with Gnus (or Emacs, this
is no Gnus specific issue!) in a Linux text console:

I managed to get good utf support (for reading post in utf-8 AND for
typing in all the characters (Umlaute, tilde etc.) I want) by using
filterm and its dynafont filter.

I launch Gnus like this:

LC_CTYPE=de_DE.utf8 exec filterm - dynafont emacs -nw --eval
"(set-keyboard-coding-system 'latin-9)" -f gnus-unplugged "$@"

(I need the "exec", by the way, when using a bash script - otherwise, it
doesn't work...)

Everything appears to be all right (reading utf-8 messages, typing in
Umlaute, euro sign etc.), but there is this one


control-g doesn't work any longer! (or in other words: keyboard-quit)

This is very bad because I often need to abort a command.
In many cases (like aborting a M-x... sequence) ESC-ESC-ESC is a good

When loading articles for a very large group (thousands of articles,
which will take a lot of time anyway) I can no longer abort that
command, because control-g is not being recognized any more (and
ESC-ESC-ESC doesn't work for interrupting a running command anyway).

I tried to remap control-g to e.g. F6 (function key 6) or other keys I
tried, but nothing works - it looks like control-g is something very
special and that the code of Emacs doesn't allow for changing that!

This means, running commands can no longer be interrupted/aborted when I
use a utf-8 enabled Emacs/Gnus in a Linux text console.

Does anyone have experience with this problem - or even better have a

many thanks

reply via email to

[Prev in Thread] Current Thread [Next in Thread]