[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Autoload failed to define function mwheel-install

From: Kevin Rodgers
Subject: Re: Autoload failed to define function mwheel-install
Date: Mon, 27 Dec 2004 10:19:37 -0700
User-agent: Mozilla Thunderbird 0.9 (X11/20041105)

Bob Marcum wrote:
I received this message upon starting up emacs after upgrading from RedHat 7.1 
Fedora Core 3, now using emacs 21.3.  I struggled for a while trying to 
a solution.  A search using google for this error message found one person's
experience which gave some guidance.

I solved this problem by including the line (load
"usr/share/emacs/21.3/lisp/mwheel.elc") as the first line in my .emacs startup

I know this is surely not the _right_ way to solve this problem.  This following
line should have solved the problem, but it doesn't.
( autoload 'mwheel-install "mwheel" "Enable mouse wheel support" t)

I would have thought emacs would look in /usr/share/emacs/21.3 and all of its
directories to find mwheel.elc and resolve the reference to mwheel in the
autoload statement, but it did not.

Is this a bug or just some configuration error I have?

I suspect you've got multiple, incompatible versions of mwheel in your
load-path.  What does `M-x list-load-path-shadows' show?

BTW, here's all I have in my .emacs to enable the mouse wheel in Emacs 21.3 (i386-pc-solaris2.8, X toolkit):

(mouse-wheel-mode 1)

Kevin Rodgers

reply via email to

[Prev in Thread] Current Thread [Next in Thread]