[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: font-lock not working correctly

From: Rodney Gordon II
Subject: Re: font-lock not working correctly
Date: Fri, 17 Dec 2004 15:45:49 -0600

On Fri, 2004-12-17 at 22:14 +0100, Peter Dyballa wrote:
> Am 17.12.2004 um 19:49 schrieb Rodney Gordon II:
> > I load is color-theme.el and cperl-mode.el
> Check whether your colour theme changes things to dull! This can be 
> done by M-x list-faces-display (also Edit menu -> Text properties -> 
> List Faces). How many colours are there?

Lots and lots of colors .. definately not what I'd call dull :)

Tried just doing 'emacs -q' .. then load the file, then 'M-x
cperl-mode', then 'M-x font-lock-mode' and it's all highlighted
correctly. Yet, putting the same in my .emacs, it's messed up again.
Seems the only way to get it to work is manually.. :/

> Check what cperl-mode.el contains to colourize the syntax and put a 
> copy of this at the end (after 1. loading color-theme and setting your 
> theme, 2. customizing font-lock as maximum) of your .emacs. Since you 
> have a screenshot you could try to change some colours ans see whether 
> this work.

Things are correct when I do what I just said above, however I have a
hard time believing its the color-theme.el because if I comment it out
of my .emacs file, the highlighting is still broken.

I have tried turning font-lock off, and then on again while I have the
perl file loaded, no help. As fas as finding what cperl-mode uses to
font-lock, I have no idea, because I am very new to lisp and just the
sheer size of that file scares me :)

Thanks for all your help, and I hope we can figure this out!
Rodney Gordon II (meff)             |         meff <at> pobox <dot> com         |                      AIM: mefforz

Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]