[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

font-lock not working correctly

From: Rodney Gordon II
Subject: font-lock not working correctly
Date: Fri, 17 Dec 2004 12:49:22 -0600

I am using emacs21 on Debian sid, to start things off.
The only elisp I load is color-theme.el and cperl-mode.el, both latest

Attached is a image, showing the problem, and my .emacs file.

With my setup, font-lock never seems to highlight things like it should.
It highlights, but maybe only 2 or 3 colors. I have tried c files and
perl files, which work perfectly fine on others' systems with emacs (I
don't know if their system is different or not).

What I get is shown on the attached image, which is hardly helpful :)
The odd thing is that if I run emacs -q and do the things in my .emacs
file *manually*, it highlights perfectly.

Have asked on #emacs on FreeNode, but nobody seems to have an idea :/
I am hoping I am doing something simple wrong..

Any help would be greatly appreciated. Please mail me directly.

Rodney Gordon II (meff)             |         meff <at> pobox <dot> com         |                      AIM: mefforz

Attachment: messed.jpg
Description: JPEG image

Attachment: dotemacs
Description: Text document

Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]