[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: X11 Mac OS X 10.3 emacs fink: only terminal?

From: Emar
Subject: Re: X11 Mac OS X 10.3 emacs fink: only terminal?
Date: 13 Dec 2004 08:33:01 -0800
User-agent: G2/0.2

D P Schreber wrote:
> On 2004-12-13, Emar <address@hidden> wrote:
> > Here's my problem: I installed Emacs with X11 support through Fink
> > Mac OS X 10.3.
> You installed a precompiled binary package (with dselect or apt-get)
> you built it from sources ('fink install ...')?
source, with "fink install"
> > I've done it before and it worked great, but now I can't
> > seem to get Emacs out of terminal mode. I can only launch it from
> > Apple's and X11 terminals (after setting the PATH
> > variables to include /sw/bin/)
> If you define PATH in ~/.MacOSX/environment.plist to include /sw/bin,
> you won't have to go through an intermediate shell in this way.

Yeah, I recently found out about that and did just that.
> > and then it stays in the terminal
> When you launch it from the xterm, where is /sw/bin on PATH? To put
> another way, what does 'which emacs' say?

"which emacs" gives "/sw/bin/emacs", as it should
> When you launch from Terminal, what's the value of DISPLAY?

"echo $DISPLAY" gives ":0.0"
> > Apple X11 (based on Xfree4.3.0)
> Did you install the X11 developer package as well?

yeah, downloaded and installed (some components of) XCode 1.5 (I'll
re-install it to see if I missed something)

Concerning your other point: I tried two carbon builds but they didnt
work well somehow, at least one had problems with emacsclient/server,
and then I use xdvi (with emacs/latex) under X11 so I couldnt get rid
of X11 anyway

reply via email to

[Prev in Thread] Current Thread [Next in Thread]