help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "./configure" problem with version 21.3 in redhat 9 linux


From: Kai Grossjohann
Subject: Re: "./configure" problem with version 21.3 in redhat 9 linux
Date: Sat, 27 Dec 2003 22:59:11 +0100
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.2 (gnu/linux)

kroy <address@hidden> writes:

> This is my first post here and i hope i don not ask a stupid
> question, i have realy tried to find the answer in many places. Also
> I am very new to Linux.
>
> I installed an older emacs version when i installed redhat linux, but
> uninstalled it with redhats "add/remove applications"
> ("redhat-config-packages").
>
> The problem I am having is that when i ran:
> ./configure
> make
> make install
> everything went fine (i could run emacs, but only in the terminal), but
> configure did not find xwindows.
> I used CFLAGS='-O2 -fomit-frame-pointer -s -pipe'.
>
> So i added --with-x11, but it still did not work.
>
> Then i added the paths to xwindows includes and libs:
> --x-include=/usr/X11R6/include and --x-libraries=/usr/X11R6/lib



> And now it found X11, but NOT rm, mkdir ...? Why does it not find these
> standard commands that i have in /bin? (these are found if i remove the x11
> include and lib paths):
>
> The configure process finished:
> $ CFLAGS='-O2 -fomit-frame-pointer -s -pipe' ./configure
> --x-include=/usr/X11R6/include/ --x-libraries=/usr/X11R6/ --with-x11

Did you specify "/usr/X11R6/" or "/usr/X11R6/lib" for --x-libraries?
"/usr/X11R6/lib" is probably correct.

> gcc -c -D_BSD_SOURCE -DHAVE_CONFIG_H -I. -I../src
> -I/usr/local/src/emacs-21.3/lib-src -I/usr/local/src/emacs-21.3/lib-src/../src
> -D_BSD_SOURCE  -I/usr/bin -I/bin -I/usr/X11R6/bin -O2 -fomit-frame-pointer -s
> -pipe -Demacs  /usr/local/src/emacs-21.3/lib-src/movemail.c
> /usr/local/src/emacs-21.3/lib-src/movemail.c: In function `strerror':
> /usr/local/src/emacs-21.3/lib-src/movemail.c:947: conflicting types for
> `sys_errlist'
> /usr/include/bits/sys_errlist.h:28: previous declaration of `sys_errlist'
> make[1]: *** [movemail.o] Error 1
> make[1]: Leaving directory `/usr/local/src/emacs-21.3/lib-src'
> make: *** [lib-src] Error 2

sys_errlist.  Hm.  The /usr/include/bits directory looks strange, but
I don't know enough about Redhat to say for sure.

But the configure output indicated that it was using a lot of cached
values.  Maybe the cache was b0rked by some previous attempt with
wrong values.  So I suggest to "rm config.cache" and try again.

Also, you were using a lot of parameters to "./configure", especially
the setting for the C compiler.  How about you try to leave that out,
leaving only the following?

    ./configure --with-x11 --x-include=/usr/X11R6/include 
--x-libraries=/usr/X11R6/lib

Kai


reply via email to

[Prev in Thread] Current Thread [Next in Thread]