help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How do I get latest CVS and compile Emacs?


From: Martin Stone Davis
Subject: Re: How do I get latest CVS and compile Emacs?
Date: Sun, 14 Dec 2003 23:52:35 -0800
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Harald Maier wrote:

Martin Stone Davis <address@hidden> writes:


Harald Maier wrote:


Martin Stone Davis <address@hidden> writes:


I would like to get the latest CVS of emacs and compile it for Windows
XP. I read http://savannah.gnu.org/statement.html, but I don't know
what I'm supposed to do.

My (lack of) experience: I am an almost-total newbie to CVS.  I have
some experience using Eclipse to access and compile a CVS Java
project.  I have emacs 21.3.1 loaded and I also have MS Visual Studio
6.0 (not loaded).

You need a cvs client program. I am using the cvs program from the
cygwin.com port but I think you should also be able with the eclipse
program. Important is the CVSROOT and that you are using the SSH. In
the following command the CVSROOT is
address@hidden:/cvs-latest/emacs
,----
| $ export CVS_RSH=ssh
| $ cvs -z3 -d:ext:address@hidden:/cvs-latest/emacs co emacs
`----

I tried this and I get the following message:

cvs [checkout aborted]: cannot start server via rsh: No such file or
directory

I tried both a command-line version in windows (where I used set
CVS_RSH=ssh) and also I tried using WinCVS.  Both gave me the same
result.

What am I doing wrong?


Do you have a ssh program? You need a secure shell. My dark shot is
that you don't have one.

True, at the time I didn't. However, I got PuTtY and copied pscp to my CVS directory. I continued to get errors, but of a different sort:

Fatal: More than one remote source not supported
cvs [checkout aborted]: end of file from server (consult above messages if any)


When I run pscp alone, I get this:

S:\CVS>pscp -r -v address@hidden:/cvs-latest/emacs S:\CVS\local
Looking up host "cvs.gnu.org"
Connecting to 199.232.41.2 port 22
Server version: SSH-2.0-OpenSSH_3.4p1 Debian 1:3.4p1-1.woody.3.1
We claim version: SSH-2.0-PuTTY-Release-0.53b
Using SSH protocol version 2
Doing Diffie-Hellman group exchange
Doing Diffie-Hellman key exchange
Host key fingerprint is:
ssh-rsa 1024 80:5a:b0:0c:ec:93:66:29:49:7e:04:2b:fd:ba:2c:d5
Using username "anoncvs".
Access granted
Opened channel for session
Primary command failed; attempting fallback
Started a shell/command
Connected to subversions.gnu.org

Server sent command exit status 0


Any clue?


Harald






reply via email to

[Prev in Thread] Current Thread [Next in Thread]