help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How do I get latest CVS and compile Emacs?


From: Harald Maier
Subject: Re: How do I get latest CVS and compile Emacs?
Date: Mon, 15 Dec 2003 08:36:52 +0100
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3 (gnu/linux)

Martin Stone Davis <address@hidden> writes:

> Harald Maier wrote:
>
>> Martin Stone Davis <address@hidden> writes:
>>
>>>I would like to get the latest CVS of emacs and compile it for Windows
>>>XP. I read http://savannah.gnu.org/statement.html, but I don't know
>>>what I'm supposed to do.
>>>
>>>My (lack of) experience: I am an almost-total newbie to CVS.  I have
>>>some experience using Eclipse to access and compile a CVS Java
>>>project.  I have emacs 21.3.1 loaded and I also have MS Visual Studio
>>>6.0 (not loaded).
>> You need a cvs client program. I am using the cvs program from the
>> cygwin.com port but I think you should also be able with the eclipse
>> program. Important is the CVSROOT and that you are using the SSH. In
>> the following command the CVSROOT is
>> address@hidden:/cvs-latest/emacs
>> ,----
>> | $ export CVS_RSH=ssh
>> | $ cvs -z3 -d:ext:address@hidden:/cvs-latest/emacs co emacs
>> `----
>
> I tried this and I get the following message:
>
> cvs [checkout aborted]: cannot start server via rsh: No such file or
> directory
>
> I tried both a command-line version in windows (where I used set
> CVS_RSH=ssh) and also I tried using WinCVS.  Both gave me the same
> result.
>
> What am I doing wrong?

Do you have a ssh program? You need a secure shell. My dark shot is
that you don't have one.

Harald


reply via email to

[Prev in Thread] Current Thread [Next in Thread]