help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: mail: Sending...failed with exit value 71


From: gebser
Subject: Re: mail: Sending...failed with exit value 71
Date: Sun, 7 Dec 2003 14:59:08 -0500 (EST)

Though I read the whole section on Email already, I thought it might be
hidden somewhere else, so I ran a search on "error code" and on "exit
value" and neither returned a hit.  Nor did a grep of the entire emacs
subtree return anything of consequence.  Googling for 'emacs "exit
value"' returned about 1600 hits; I browsed the first six pages and
didn't see anything that appeared to be relevant.  A search of the Info
pages for emacs also found nothing.  Looking at the manpage and in
doc/emacs likewise yeilded zilch.  I'm sure there's a Table of Exit
Values for Emacs out there somewhere.  It would make a nice addition to 
the supplied documentation, also a handy webpage.  (Nobody can say I 
don't have an Exit Strategy.)

Back to the main topic....

For no particular reason at all, I fired up Xemacs (which I never used
before, though I've been using emacs daily since about 1992) and got an
init error.  Despite this, I wanted to see what the mail interface
looked and worked like.  I sent myself a test email, fully expecting it
to fail just like it did in emacs.  But the mail went through.  It
worked without any error at all.  "Hmmm...", I thought to myself.  
"Xemacs and Emacs are using the same init file (~/.emacs).  So,
probably, because Xemacs horked on my .emacs, it must have stopped
reading it before getting to the various definitions relevant to
handling mail (towards the end of the file).  So it used the defaults
instead... and they worked."  I'm using emacs v.20.7.1 and xemacs v.21.1 
(patch 14) "Cuyahoga Valley" [Lucid] ....  (The latter is called 
"Cuyahoga Valley"?  If so, anyone know why?)

I'll continue to dig into this, but if anyone has a tip or comment on 
any of the above-- or any of the below-- feel free.


tnx,
ken                                                                             
                                                                             



At 22:41 (UTC-0500) on Sat, 6 Dec 2003 address@hidden said:

= 
= Funny, sending mail with emacs was set up and working fine some months
= ago (just to try it out-- to check it out), but it isn't anymore.  
= 
= It's 99.999% certain that there's something not configured in the emacs
= MUA.  My regular email tool, pine, has been and still is working just
= fine forever.  With ngrep sniffing port 25, I can see that nothing
= getting outside.  The logs say
= 
= sendmail[4986]: hB725mJ04986: SYSERR(ken): Can't create transcript file 
= ./xfhB725mJ04986: Permission denied
= 
= In emacs' *Messages* buffer I'm seeing
= 
= Sending...
= Sending...failed with exit value 71
= 
= How do I find out what 71 is/means?
= 
= Better yet, what needs to be changed?
= 
= 
= 
= 
= 
= 
= _______________________________________________
= Help-gnu-emacs mailing list
= address@hidden
= http://mail.gnu.org/mailman/listinfo/help-gnu-emacs
= 





reply via email to

[Prev in Thread] Current Thread [Next in Thread]