help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How do I check the latest version of Emacs out of CVS?


From: Simon Josefsson
Subject: Re: How do I check the latest version of Emacs out of CVS?
Date: Wed, 26 Nov 2003 14:37:54 +0100
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3.50 (gnu/linux)

Eli Zaretskii <address@hidden> writes:

>> From: address@hidden (Rainer Volz)
>> Newsgroups: gnu.emacs.help
>> Date: 26 Nov 2003 02:09:55 -0800
>> 
>> I had a  problem with SMTP AUTH too and followed the link
>> http://savannah.gnu.org/cgi-bin/viewcvs/emacs/emacs/lisp/mail/smtpmail.el?rev=HEAD&content-type=text/vnd.viewcvs-markup
>>  from Simon Josefssons page
>> (http://josefsson.org/emacs-smtp-starttls.html). It leads directly to
>> smtpmail.el.Much simpler.
>
> Much simpler, but also more risky: the CVS version of smtpmail.el
> might need updated versions of other files and might use extensions
> and enhancements outside itself.
>
> But if you are sure that in this particular case, there's no such
> dependencies, then fetching smtpmail.el alone is indeed much simpler.

sendmail.el and netrc.el are also needed from CVS, if you use
smtpmail.el.  At least some time ago, today even more files may be
required...

It would be nice of someone wanted to take over maintaining the
SASL/STARTTLS SMTP support for Emacs 21.3, I have problems even
keeping up with making it work in HEAD.  (The latest starttls.el
posted to gnu.emacs.sources being to first step to improve the
situation in HEAD, where it currently implicitly uses non-free
tools...)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]