help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

emacs + netscape copy&paste coding problem


From: Stephan Graf
Subject: emacs + netscape copy&paste coding problem
Date: Mon, 17 Nov 2003 10:09:59 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0

Hi!

I use emacs 21.2 on a linux-system (precompiled (SuSE) and self compiled) and netscape 7.0 ( Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0 ).

If I copy&paste Text from emails or web-pages into an emacs-buffer, special characters like öüäß (german Umlaute + sz) are lost.
In Netscape, the Coding-sytsem is set to ISO-8859-1 (View-Character Coding).
I tried different functions and variables, but I had no success (some example):
 (set-language-environment "latin-9")
 (setq selection-coding-system "raw-text")
 (setq selection-coding-system "iso-8859-1")
 (set-default-coding-systems 'iso-8859-1 )
 (set-clipboard-coding-system 'iso-8859-1)
 (setq clipboard-coding-system 'raw-text)

The special characters are replaced by '?' or 'o"' (if I use (setq selection-coding-system "iso-8859-1") and copy&paste a 'ö').

Thanks in advance!

Stephan

--
Stephan Graf                       Forschungszentrum Juelich GmbH
Tel: 02461/61-6578                 ZAM, Abt. IuT-BuB
E-Mail: address@hidden      FAX: 02461/61-6656
Webseite:                          http://www.fz-juelich.de/zam



reply via email to

[Prev in Thread] Current Thread [Next in Thread]