help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: comint-mode broken in GNU Emacs 21.2.1?


From: Vincent Montressor
Subject: Re: comint-mode broken in GNU Emacs 21.2.1?
Date: 22 Sep 2003 03:24:14 -0700

"Stefan Monnier" <address@hidden> wrote in message news:<address@hidden>...
> >     error in process filter: Wrong type argument: markerp, nil
> > Does anyone know how to fix this?
> 
> The usual way: set debug-on-error, reproduce the error, look at the
> backtrace, if you don't know what to do then, post the backtrace for more
> info, ...

The compile-input.el solution posted by Kevin Rodgers solved the
problem for me (thanks!), so I am back in business.  (Indeed, this
solution is even nicer than using comint-mode, since I don't have to
change modes in the compilation buffer.)

Just out of curiosity, I did as you suggested above, using comint-mode
as before, and got this backtrace:

Debugger entered--Lisp error: (wrong-type-argument markerp nil)
  marker-position(nil)
  compilation-filter(#<process compilation> "hello, world\n")

I can't afford the time to explore it further now, especially since my
problem is solved, but anyone else who's interested now has that as a
starting point.

Thanks to both of you for your assistance.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]