help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs/w3 problems(console, images, CVS)


From: Kevin Rodgers
Subject: Re: emacs/w3 problems(console, images, CVS)
Date: Fri, 15 Aug 2003 14:32:39 -0600
User-agent: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:0.9.4.1) Gecko/20020406 Netscape6/6.2.2

Alexander Nikolov wrote:

Kevin Rodgers <address@hidden> writes:


Alexander Nikolov wrote:


I got the url package from CVS and now starting W3 gives the following
error(I post the debug information):
,----
| Debugger entered--Lisp error: (invalid-function (macro . #[(handle) " 
%/1Ђ?microsoft-cp1251 БВE %/1Ђ?microsoft-cp1251 ?" [handle nth 2] 3]))
|   mm-handle-encoding((#<buffer  *mm*<2>> ("text/html") nil nil nil nil nil 
nil))
|   w3-decode-charset((#<buffer  *mm*<2>> ("text/html") nil nil nil nil nil 
nil))
|   w3-fetch-callback("http://www.cs.indiana.edu/elisp/w3/docs.html";)
|   apply(w3-fetch-callback "http://www.cs.indiana.edu/elisp/w3/docs.html";)
|   url-http-activate-callback()
|   url-http-wait-for-headers-change-function(1 185 184)
|   url-http-generic-filter(#<process www.cs.indiana.edu> "HTTP/1.1 304 Not Modified\nDate: 
Wed, 13 Aug 2003 08:45:00 GMT\nServer: Apache/1.3.27 (Unix) PHP/4.2.3 mod_ssl/2.8.11 
OpenSSL/0.9.6e\nConnection: close\nETag: \"148a7e-b86-3c02cee1\"\n\n")
`----

That means that mm-handle-encoding calls a macro which was not defined when
it was byte compiled.  Recompile it (you may as well recompile all the W3 .el
files).

,----[ C-h f mm-handle-encoding RET ]
| mm-handle-encoding is a Lisp macro in `mm-decode'.
| (mm-handle-encoding HANDLE)
| not documented
`----


Ah, perhaps it was w3-decode-charset that was compiled without the
mm-handle-encoding macro being defined.


Compiling mm-decode gives the following error:
,----
| Compiling file /usr/share/emacs/21.2/lisp/gnus/mm-decode.el at Thu Aug 14 
13:10:14 2003
|   ** The following functions are not known to be defined: temp-directory,
|     delete-annotation, make-glyph, glyph-width, window-pixel-width,
|     glyph-height, window-pixel-height,
|     valid-image-instantiator-format-p
`----

I downloded the emacs/lisp/gnus directory from the CVS repository and
recompiled all the files in it and then recompiled w3 and I still get
the same error. Any ideas what are these undefined functions in the error message above?

Uh, because you're not running the CVS version of Emacs?

--
Kevin Rodgers



reply via email to

[Prev in Thread] Current Thread [Next in Thread]