help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem getting hooks to be active


From: Eric Pement
Subject: Re: problem getting hooks to be active
Date: 15 Aug 2003 07:54:01 -0700

Peter Solodov <address@hidden> wrote in message news:<address@hidden>...
> On 12 Aug 2003, Eric Pement wrote:
> > So what should I have written instead that will change the variables
> > while in sgml-mode?
> 
> (add-hook 'sgml-mode-hook
>   (lambda ()
>     (setq tab-width 2)
>     (setq indent-tabs-mode nil)
>     (setq fill-column 85)))
> 
> That code worked just now.  It doesn't appear very different (or at
> all) from what you've shown.
> 
> Put code above into "*scratch*" buffer and evaluate it (press "C-x
> C-e" at the end of the last line).  Then try to open SGML file.  If
> that works, then you're not putting your code into the right place.
> 
>         - Peter

Wow, that was really a great answer. Thanks for being so direct and
helpful. As it turns out, it worked when I put it into the *scratch*
buffer and followed your instructions. But when I put it into my
.emacs file, it doesn't work. I tried moving it to the very FIRST
instruction at the top, and also to practically the LAST instruction
... technically, just above the "custom-set-variables" line. But in
neither case does it change things for my XML files. (sigh)

I guess my next step is a slow, line-by-line debug. Well, at least
you've put me on the right track. I think I can manage from here.

--
Eric Pement


reply via email to

[Prev in Thread] Current Thread [Next in Thread]