[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

backspace (don't kill me)

From: John Hunter
Subject: backspace (don't kill me)
Date: Tue, 12 Aug 2003 10:05:23 -0500
User-agent: Gnus/5.090013 (Oort Gnus v0.13) Emacs/21.2 (i686-pc-linux-gnu)

I am experiencing some backspace weirdness.  I know this the FAQ to
end all FAQs, and I've read the FAQ and some other web resources but
I'm still stumped.

I have put (global-set-key [backspace] 'delete-backward-char)
in my .emacs, yet when I hit the backspace key, I get delete (deletes
char at point).  When I do M-x delete-backward-char, it performs as
desired (deletes previous char) and advises me that I could use
<backspace> as a shortcut.

Backspace is apparently backspace as far as my term is concerned,
because at the shell, backspace does in fact delete the previous

I get the same behavior (delete char at point) when I run emacs with
-q -nw --no-site-file

I am running emacs over ssh in an xterm.  The local machine is RHL 8.0
and the remote machine is free bsd (see below for full version info).
When I run emacs under X with X11 forwarding, backspace works as

To make matters worse, the C-h b, C-h k bindings don't work (they just
insert 'b' and 'k' into the buffer so I can't easily debug the key
bindings.  However, CTRL, as in C-x b, does work to switch buffers, so
it's not a CTRL problem.

Arggg, I thought I was beyond this!

Any ideas?

John Hunter

GNU Emacs 21.3.1 (i386--freebsd, X toolkit, Xaw3d scroll bars) of 2003-05-24 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]