[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

problem getting hooks to be active

From: Eric Pement
Subject: problem getting hooks to be active
Date: 11 Aug 2003 10:34:00 -0700

I'm trying to customize a few variables in sgml-mode (xml-mode), but
the settings I want are not being obeyed. I don't know why, so I
thought I'd post my .emacs snippet here and maybe someone could tell
me what I'm doing wrong:

   (add-hook 'sgml-mode-hook'
        (lambda ()
          (setq tab-width 2)
          (setq indent-tabs-mode nil)
          (setq fill-column 85)

What I want should be obvious. When editing XML files, I want to
change my tab width, fill column, and intent-tabs-mode behavior. But
my alterations aren't being obeyed. I've tried adding --debug-init on
the command line, but it doesn't bring up the debugger at all. I've
tried doing M-x eval-buffer while editing my .emacs file, and
eval-last-sexp after the function above, and gotten no error messages
that I can detect. Any advice?

I'm running GNU Emacs version 21.1.1 on Windows 2000 Pro, with 4NT as
the basic shell.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]