[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

updating cperl-mode fails me, why?

From: i5513
Subject: updating cperl-mode fails me, why?
Date: 8 Jun 2003 07:13:08 -0700

Hi! I have emacs 21.2, from Red Hat 9. cperl-version by default is
4.23 it works fine with same bugs. I'd like to upgrade to 4.32 or 4.35
or 5.0, but this upgrade fails me. What am I do wrong?

I download cperl-mode-4.xx.el and cp it as cperl-mode.el to

As root I run emacs, and compile cperl-mode.el, it creates
I exit emacs

I run emacs with my home user. Open a file .pl and colors not are
display (all black (except comments, quoted strings and i qualifiers
(at s/../i)).
When I edit a line, it cames to color, by example print goes to green
and sub goes to pink and function names goes to blue.

When I tipe a new line this occur:
imagine I want to put use strict, before of use Getopt::Long 

Step 1
use (without space after use)
use Getopt::Long;

It is ok (use is pink and strict is blue).

Step 2
use (with space after use)
use Getopt::Long;
It is nok (use is black) after a short while, use strict is all black.

Step 3
use strict
use Getopt::Long
It is ok (two use are pink)

Step 4
use strict (with a space)
use Getopt::Long
It is nok (two uses goes to black and Getopt::Long)
Step 5
use strict ;
use Getopt::Long
It is ok (all colors are ok).

Last Step
use strict ; (with space)
use Getopt:Long
It is nok (all black like at start)

It occurs me with 4.32, 4.35 and 5.0 but it doesn't occur me with
original 4.23

How can I fix my problem? Thanks you and sorry for my poo english

reply via email to

[Prev in Thread] Current Thread [Next in Thread]