help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Has anyone successfully compiled NtEmacs with fully image support?


From: lawrence mitchell
Subject: Re: Has anyone successfully compiled NtEmacs with fully image support?
Date: Mon, 02 Jun 2003 17:42:05 +0100
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3.50

Robin Hu wrote:

> Hi Everyone:

>    I am tring to compile NtEmacs (current cvs version) with fully image
>    support (I mean gif, jpg, png, xpm and tiff).

>    While I am trying to compile with mingw (runtime 3.0 + gcc 3.2.3 +
>    winapi 2.3), NtEmacs failed to display jpg images. And while I am
>    compiling with MSVC (msvc 7.1), NtEmacs will trigge an access
>    exception while loading gif file or png file.

This is a bug.  You can report it using M-x report-emacs-bug RET
when running Emacs.  Alternately, someone on emacs-devel might
have an idea as to what is not working, though, without some
kind of backtrace, it's a bit tricky :).

>    I remember someone in this list once mentioned he had successfully
>    compiled NtEmacs with fully image support, can you offer some hint?

I have managed to compile Emacs with mingw and gotten image
support working.  A few things:
* do you have both the dlls /and/ the header files for the
  relevant image libraries you are compiling with?

* Does Emacs find the /correct/ image dlls when it starts up.
  It may be that you have multiple, incompatible, dlls for (say)
  libjpeg on your system.  Make sure that the one you should be
  using sits in a directory near the beginning of your PATH.
  This could be what is causing access exceptions, the image dll
  Emacs is loading might not be the correct one.

Other than that, you might want to try picking up an unofficial
CVS binary, I believe <URL: http://www.crasseux.com/emacs/> has
one, not sure how up-to-date it is.

-- 
lawrence mitchell <address@hidden>


reply via email to

[Prev in Thread] Current Thread [Next in Thread]