[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Does Carbon Emacs ignore ~/.emacs ?

From: Joe Davison
Subject: Re: Does Carbon Emacs ignore ~/.emacs ?
Date: Thu, 08 May 2003 15:08:52 GMT
User-agent: Gnus/5.1001 (Gnus v5.10.1) XEmacs/21.5 (brussels sprouts, darwin)

On 7 May 2003, address@hidden wrote:
>  Joe Davison <address@hidden> wrote ...
> > > > Isn't there a version of emacs for aqua?
> > >  
> > >  Yes, that's the "carbonised" Emacs, hence Carbon Emacs, I am
> > >  talking about.
> > >  
> > That's good to know, I use it when I don't feel like starting X11
> > and using xemacs.  However the version at
> > appears to be version 20.7
> > while you started off talking about version 21.1.30, which I presume
> > you built yourself?
>  No, I downloaded it as a binary from
>  However, at this point in time, I have to ***stress*** that I do
>  *not* recommend this build *at all*. For me, it exhibits behaviour
>  that I am convinced no Emacs user would ever tolerate. YMMV, but you
>  have been warned ;-)

I've read the other thread. Have you tried the version I mentioned?  I
know the "7.0.1" version ran on 10.1.5, because I  was using it -- it
broke when I moved to 10.2, so there are clearly compatibility issues
there.  However, the version I was using on 10.1.5 did NOT have most of
the problems you mentioned.  Almost all "normal emacs" commands worked,
including C-x modifier commands and the kill & yank (cut & paste)
commands -- using the "normal emacs" keybindings.  Mac conventions were
NOT followed, but the version was very functional -- nothing like the
problems you've mentioned.  With the version I'm running, the situation
is almost the same, although there is more mac-like functionality -- For
instance, drag & drop pasting works one-way -- mac-app (Safari) to
emacs, but not the other direction.   C-x C-c works to quit, as does the
"Quit Emacs" menu item, but not the window close button.  As an added
"feature" :-) Cmd-C (mac copy) also quits the application,
"unexpectedly".  This is on 10.2.5 (and 10.2.6), so it's only of
academic interest to you.   Since it sounds like the later versions
don't have this problem, it's probably time for me to follow the advice
and build myself a new version.

I do wish you luck in getting answers to your specific questions.  I
suspect the simplest answer for your ilisp startup docs might be -
"you'll be better off by far if you upgrade to Jaguar before you try
this", since I suspect everything works, including the mac cut & past by
setting the key-bindings that were listed.  

The Jaguar upgrade is worth the price (if you've got the funds) -- for
lots of reasons.  It also will require upgrading your Developer Tools,
but there's a DevTools CD among the others, at least in my upgrade
package.   I think they've been upgraded again (December,2002) however,
so you'd want to download/copy the CD for those, too.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]