[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: New Surface computer, several problems

From: Allen Windhorn
Subject: Re: New Surface computer, several problems
Date: Wed, 16 Nov 2022 10:53:55 -0600

On Tue, Nov 15, 2022 at 6:55 AM Eli Zaretskii <> wrote:
> >
> > I have a new computer, running Windows 11.
> You have my sympathy ;-)

In my defense, I also have a Linux machine, where Emacs works fine.

> ...
> I don't think I understand what do you mean by "closing the last
> buffer".  How about if you describe this in terms of Emacs commands or
> key sequences that you type, and tell at which step would you like
> Emacs to ask for confirmation.

Clicking the "X" in the UR corner, or selecting "Exit" on the menu, or
typing Ctrl-X Ctrl-C, to close the session.

> > (2) when Emacs starts, the font is #5 and the window is tiny. I can't
>> figure how to set it to a larger font and stay that way.
> Does invoking Emacs as "emacs -fn "Courier New-15" change the window
> size?  If it does, try to find the number instead of 15 that gives the
> best results.  Then, inside Emacs type:

No, it comes up initially a different size, but immediately reverts to the mini

>   M-: (face-font 'default) RET

setting to 25, did this and got:

> This will show a long string that defines the font you are using.  Add
> the following line to your ~/.emacs init file:
>   (add-to-list 'default-frame-alist '(font . "FONT"))
> where FONT is that long line specifying the font

That worked!

> > (4) when I try to print, I get something like "permission denied: Epson 
> > RS480".
> Suggest to read the "Windows Printing" node in the Emacs user manual,
> it describes several possible methods of solving this.

Manual? We don't need no steenking manual :-) Oh, OK, if I have to...

> > (5) the default directory is c:emacs-xx.x despite having HOME set to my
>> home directory.
> Check the "Start in" property of the icon or the shortcut through
> which you invoke Emacs: it specifies the directory in which Emacs
> should start.

Also worked!

> > and (6) I can't double-click a text file and have it open in Emacs any more.
> In File Explorer?  You need to set up Emacs as the default application
> for TXT files.

Thanks, I used to know how to do that -- will look into it. Will it
work with a running
Emacs? Thought there was a daemon needed to be running.

Thanks much for your help!

Allen Windhorn
P.O. Box 320
Kasota, MN  56050  USA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]