[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [h-e-w] EmacsW32 and viper

From: Denny Wright \(dennyw\)
Subject: RE: [h-e-w] EmacsW32 and viper
Date: Mon, 11 Sep 2006 16:18:49 -0700

Awesome, Lennart!

That worked perfectly. I appreciate the help.


-----Original Message-----
From: Lennart Borgman [mailto:address@hidden 
Sent: Monday, September 11, 2006 3:33 PM
To: Denny Wright (dennyw)
Cc: address@hidden
Subject: Re: [h-e-w] EmacsW32 and viper

Denny Wright (dennyw) wrote:
> Hi Lennart,
> Thanks for your response. I've trimmed down my .emacs/.viper files to 
> the minimim that I think I need to get viper working. So they look
> ~/.emacs:
> ;; load viper
> (setq viper-mode t)
> (require 'viper)
> ~/.viper:
> (setq viper-inhibit-startup-message 't) (setq viper-expert-level '5)
> For example, I open a .txt file (bound to gnuclientw) from the
> Emacs comes up, shows the EmacsW32 splash page, and then the .txt
> The status bar shows (V). I try the 'j' & 'k' movement keys and it
> inserts characters. The odd thing now, is that I'm trying this as I
> this email in Outlook, so I'm switching back and forth and reopening
> file. In one test, I opened the file, switched to Outlook, switched
> and it worked?!? It seems like there was a delay in
> viper-mode. That may be why C-z or M-x viper-mode doesn't fix it
> immediately and it seems like playing around with M-x does. I'm
> that whatever is causing the delay finally completes (5-10 seconds or
> so). 
> Here is the *Messages* buffer after it starts working correctly.
> (C:\Program Files\Emacs\emacs\bin\emacs.exe --load=C:/Program
> Files/Emacs/EmacsW32/bin/gnuservauto.el)
> Loading encoded-kb...done
> Adding c:/Program Files/Emacs/EmacsW32/lisp/ to load-path
> Loading c:/Documents and Settings/dennyw/Application
> Loading cl-macs...done
> Loading cl-seq...done
> Loading easy-mmode...done
> For information about the GNU Project and its goals, type C-h C-p. [4
> times]
> forward-sentence: End of buffer
> For information about the GNU Project and its goals, type C-h C-p.
> Auto-saving...done
> My first thought was gnuserv or viper mode, but I get the two "GNU
> Project" messages while its still inserting characters. Is there some
> other background process that's running?
> Thanks
> Denny
Hi Denny,

Thanks for testing. I can reproduce the error here now. I will try to 
look into it.

It seems like this has something to do with the splash screen. If I turn

off the splash screen the problem disappears.

To turn off it do

    M-x customize-option RET
    Customize variable: inhibit-splash-screen

and then set inhibit-splash-screen to "on" and save the value.

Does the problem disappear for you if you do this?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]