[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Re: Possible bug in Emacs 21.3

From: David Ponce
Subject: Re: [h-e-w] Re: Possible bug in Emacs 21.3
Date: Sat, 29 Mar 2003 10:53:13 +0100
User-agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4a) Gecko/20030328

address@hidden wrote:

The following message is a courtesy copy of an article
that has been posted to gnu.emacs.bug as well.

"Peter Milliken" <address@hidden> writes:

I have downloaded the source of 21.3 and built it on a PC running Win2000
and using the Cygwin distribution and following the INSTALL instructions in
emacs-21.3/nt/INSTALL (well, I ran "configure.bat --prefix=/c/emacs" and
then type "make install" as I have done for all other source distributions

The resulting binary falls over with a "Abort, Retry or Ignore" dialog when
any package referenced from my .emacs that attempts to "require" the cl.el

Just typing M-: (require 'cl) from within the Emacs session will bring up
the problem.

I would imagine this is more likely a problem with my Cygwin setup than an
Emacs bug as I am sure that pretesting would have found this one very

I used gcc 3.2.3(?) to build emacs from the source. I then tried using gcc
2.95 but that fails with a source code/compile error part way through the
make, so I rebuilt with gcc 3.2.3 and tried again - same results.

I veryfied emacs-21.2.95 this with the latest cygwin release and I
could reproduce this on my system too. I was able to compile emacs too
with the latest cygwin 'gcc version 2.95.3-10 (cygwin special)', but
the problem still exists: cl pops up a "Abort, Retry or Ignore"

Compiler                          | State
gcc    2.95.3-10 (cygwin special) | fails with cl.el
gcc 3.2 20020927 (prerelease)     | fails with cl.el
gcc     2.95.3-6 (mingw special)  | okay
msvc                              | okay

With the emacs head version I get by executing the "M-: (require 'cl)"
lisp function the following backtrace:

| Debugger entered--Lisp error: (invalid-read-syntax ". in wrong context")
|   cl-random-time()
|   byte-code("...")
|   require(cl)
|   eval((require (quote cl)))
|   eval-expression((require (quote cl)) nil)
| * call-interactively(eval-expression)

I am cc'ing this too to the cygwin mailing list, maybe someone has an
idea what the problem caused.



Maybe are you using the mingw runtime 2.3 or 2.4?
There is a compatibility problem between that runtime and Emacs,
because of change in the way it handles binary vs. text IO mode.

Notice that the development version (in CVS) is affected too.

The following patch (discussed in the emacs-devel ML) fixed that
problem for me.

Hope it will help.


*** emacs.c.ori Thu Aug 29 21:27:07 2002
--- emacs.c     Thu Mar 27 16:29:58 2003
*** 40,45 ****
--- 40,49 ----
  #include <sys/ioctl.h>

+ #ifdef WINDOWSNT
+ #include <fcntl.h>
+ #endif
  #include "lisp.h"
  #include "commands.h"
  #include "intervals.h"
*** 874,884 ****
    uninterrupt_malloc ();
  #endif        /* not SYSTEM_MALLOC */

! #ifdef MSDOS
    /* We do all file input/output as binary files.  When we need to translate
       newlines, we do that manually.  */
    _fmode = O_BINARY;

  #if __DJGPP__ >= 2
    if (!isatty (fileno (stdin)))
      setmode (fileno (stdin), O_BINARY);
--- 878,890 ----
    uninterrupt_malloc ();
  #endif        /* not SYSTEM_MALLOC */

! #if defined (MSDOS) || defined (WINDOWSNT)
    /* We do all file input/output as binary files.  When we need to translate
       newlines, we do that manually.  */
    _fmode = O_BINARY;
+ #endif /* MSDOS || WINDOWSNT */

+ #ifdef MSDOS
  #if __DJGPP__ >= 2
    if (!isatty (fileno (stdin)))
      setmode (fileno (stdin), O_BINARY);

reply via email to

[Prev in Thread] Current Thread [Next in Thread]