[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Health] Help for upgrade GnuHealth in OpenSuse 42.1

From: Tajwali Khan
Subject: Re: [Health] Help for upgrade GnuHealth in OpenSuse 42.1
Date: Tue, 6 Jul 2021 17:43:09 +0500

Thank u for the reply. I am just trying to instal a dummy system on vmware. I already had an old version. I think too much effort to update it. So took going to take a shorter route as below.

 Saw ur video on how to instal on opensuse leap 15.2

I tried doing the same on opensuse leap 15.3

I was able to set up the system. But when tried to run the client it could not find the localhost. 

I checked system services. Gnuhealth and postgress were not running. I set them up to start on boot. And rebooted system.

Stil same. 'could not connect to server'

Please help

On Tue, Jul 6, 2021, 1:26 PM Axel Braun <> wrote:
In theory yes.
First you need - after a Backup- to covert the postgres DB to the latest resp target Version
. Then you need to apply all gnu Health database patches from the Upgrade directory, in sequential order
Schöne Grüße
Written from cell phone - excuses for typos

Am 4. Juli 2021 11:40:41 MESZ schrieb Tajwali Khan <>:

I have a live  opensuse 42.1, which i installed as a vmware. GnuHealth is not the latest version.

Can I upgrade the gnuhealth to the latest version from the command line ?

On Wed, Jun 30, 2021, 1:34 PM Edgar_ <> wrote:
Dear Luis

Am 29.06.2021 um 13:49 schrieb Luis Falcon:

> Proteus is the best way to import information to GNU Health. However I
> understand your point of trying to import the file from the client.
>> The csv-file looks like this:
>> Name,Account Category,List Price,Type,Default UOM
>> ANC (Micro),General,2100.0000,Service,Unit
>> Urine MCS (Adult),Urine bench,1100.0000,Service,Unit
>> Urine MCS (Children),Urine bench,600.0000,Service,Unit
>> In Product/Categories/Categories I created first „General“ (tick
>> Accounting) and „Urine bench“ (tick Accounting).
>> When I import the csv-file then, the error occurs:
>> error: the value „Services“ on Field „Type“ on Product Template is
>> not in the selection
> Basically, "Services" is the English, human readable representation of
> the actual value. You need to use the actual value at the model level.

Thank you very much, this is an important hint! But at Models/Models I
cannot find the actual value,

and also not in Models/Fields. In models/fields there is type - product
template - selection - type

how can I find the actual value?

> Also, if things have not changed much... the CSV import did not handle
> relational fields either.
> So, because of that (and other technical reasons), I just use proteus
> for batch input.

Hm, maybe then I have to try proteus too, but I am afraid that it will
be too complicated for me - I even do not know how to start.

The import function seems to be much more intuitive. I would love to
find a way how to solve this problem for the Nigerian hospital.

Thank you very much!

All the best


reply via email to

[Prev in Thread] Current Thread [Next in Thread]