[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Health] Upgrade

From: Luis Falcon
Subject: Re: [Health] Upgrade
Date: Thu, 14 Nov 2019 21:07:03 +0000

Hi Mike !

On Thu, 14 Nov 2019 19:21:09 +0000
mike via Health <address@hidden> wrote:

> We are running Gnuhealth 3.2 on Opensuse 15.1 and tried to upgrade to
> 3.4
> We have tried to follow the instructions but fail. We are not experts
> but have installed the system in a hospital in Tanzania and need to
> upgrade it. We have brought the virtual machine to Sweden to try and
> upgrade it. We need more help and guides to succeed.
First let us know if you succeed with the issue about the calendar
package error, so we can move forward.

The error that you got initially about the product should have not
happen if you run the upgrade script first. 

> Any idea what the message below shows?
> tryton@Tryton-Server:/usr/share/doc/packages/gnuhealth/upgrade/3.4>
> /usr/bin/trytond-admin -c /etc/tryton/trytond.conf --all -d Hospital
> 14716 139755492070720 [2019-11-09 12:11:15,485] ERROR trytond.convert
> Error while parsing xml file: In tag record: model
> gnuhealth.medicament with id meds_em3.
> File "/usr/lib/python3.6/site-packages/trytond/", line 74, in
> raise_user_error raise UserError(error) trytond.exceptions.UserError:
> ('UserError', ('The value of the field "Product" on "Medicament" is
> not valid according to its domain.', ''))
> tryton@Tryton-Server:/usr/share/doc/packages/gnuhealth/upgrade/3.4>el

Check the health_who_essential_medicines package:

Please look at the two entries from the following files:


<record model="gnuhealth.medicament" id="meds_em3">
    <field name="name" model="product.product" ref="prod_em3"/>
    <field name="active_component">nitrous oxide</field>
    <field name="category" model="gnuhealth.medicament.category" 
    <field name="pregnancy_warning">1</field>
    <field name="pregnancy_category">N</field>
    <field name="notes">Inhalation</field>


<record model="product.template" id="templ_em3">
    <field name="name">nitrous oxide</field>
    <field name="default_uom" model="product.uom" ref="product.uom_unit"/>
    <field name="list_price" eval="0"/>
    <field name="cost_price" eval="0"/>

From the directory structure, it looks like you're not using the
standard installation, but the packages. Axel is the maintainer of the
openSUSE packages. I work on the standard / vanilla / generic installation. 

If the issue persists, as Axel suggested, we might have to check
your system directly. There might have been changes at your DB level that
simply can't be done via email.

Last but not least, I highly recommend to upgrade to 3.6.0, the latest
GNU Health version !


reply via email to

[Prev in Thread] Current Thread [Next in Thread]