[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Health-dev] GNU Health Occupation database - French and German tran

From: Yusif Suleiman
Subject: Re: [Health-dev] GNU Health Occupation database - French and German translation not activated
Date: Tue, 27 Apr 2021 21:55:34 +0100

Sent from my Huawei Mobile

-------- Original Message --------
Subject: Re: [Health-dev] GNU Health Occupation database - French and German translation not activated
From: Axel Braun

Hallo Edgar,

Am Montag, 26. April 2021, 22:12:21 CEST schrieb Edgar Hagenbichler:

> Hello Axel


> Am 24.04.2021 um 12:54 schrieb Axel Braun:

> > Hello Edgar,

> >

> > looks like you had a hard time....


> Yes 😉

Looks like we need to be better on documentation....

I will really appreciate this powerful suggestion. The documentation in so many occasions end-off confusing me, to which I have to suspend a process of installing gnuhealth until another time... But I am yet to achieve my goals. 


> >>> you need to use the right user, who has a role in postgres. This is

> >>> either

> >>> the user postgres, or the user tryton, see:

> >>>

> >>

> >> Now I changed first to user root (su root), then cd /tmp, then su

> >> postgres, then "createdb health38". No error so far.

> >

> > Yes, that works, but the database has the owner 'postgres' now.

> > As it is empty you can savely run

> > dropdb health38

> > and afterwards

> > createdb health38 --encoding='UTF-8' --owner=tryton


> Ok, it worked



> > As described in

> >

> >

> > you need to tell trytond-admin where the configuration file is (as long

> as you

> > have not set it in the shell environment, see Luis' mail from last days)

> >

> > So, a proper call would be

> > su tryton -s /bin/bash

> > trytond-admin -c /etc/tryton/trytond.conf --all -d health38 -v

> > (the -v is not required, but gives you some entertainment while the

> > database is initialized)


> Worked so far: as tryton@GNUHealth-Raspi4 I created the database

> health38 with email: and password: gnusolidario



> >> Searching for health38* in trytond+subdirectories => no files

> >>

> >> Searching for ghdemo38* (that is the database which connects at

> >> localhost) in root+subdirectories, also hidden files => no files

> >>

> >> Any ideas? Where can I find the database file itself?

> >

> > somehwere under /var/lib/pgsql - the standard path of a postgres database

> > (but you dont really want do do anything in there)


> At /var/lib/pgsql/data/base there are 5 folders like 1, 14049m 14050,

> 17623 and 27827, all with some files named as numbers. One empty folder

> is named as pgsql_tmp. With search from /var/lib/ +subdirectories for

> health38 there is no file. I would be interested in where is the

> database itself. Because the program does not find it too.

Why do you want to look into postgres' internal storage logic?

psql -l

tells you which databases exit (preferably ran as user postgres)


> But back to the main problem with the translation:


> Logging in again as test and starting the GH client with health38:


> worked, starting with "Module configuration" - OK and Configure Users -

> OK: Name: admin, password gnusolidario, Preferences: Language: only

> English there! access permissions: only Administration there


> again module configuration: click on the line (e.g. account), then the

> icon gearwheels, Mark for Activation: I marked all Modules (ir and res

> have already been activated). Then: Perform Pending activation/Upgrade,

> Start Upgrade (apprx 2 and 1/2 hours) Then: Configure company. Then:

> Administration Users/Users Preferences: only English!


> A look into ...modules/health/locale: 23 languages there. Go to

> administration/localizations/languages: make translatable: en, de, fr,

> es Then: synchronize translations: German: Update 2 1/2 hours


> logout, login, admin: preferences to German (also Spanish, French

> there), new login


> nevertheless there is no German, except with settings/preferences => 

> window with "Einstellung/Benutzereinstellung bearbeiten"

Here is a screenshot when I change the user 'admin' to language 'german' (nothing else, no updates, no nothing):


-> works in my opinion....

> Same with new Party: "Suche Occupation", but only english entries, but

> with "Abbrechen, Suchen, Neu" ...


> So I tried an update like described in

> as

> postgres@GNUHealth-Raspi4:


> trytond-admin --all --database=health38


> OSError: Database "health38.sqlite" doesn't exist!

you missed the parameter

-c /etc/tryton/trytond.conf

to tell tryton where it finds the configuration



reply via email to

[Prev in Thread] Current Thread [Next in Thread]