[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Health-dev] GNU Health Occupation database - French and German tran

From: Edgar Hagenbichler
Subject: Re: [Health-dev] GNU Health Occupation database - French and German translation not activated
Date: Mon, 26 Apr 2021 22:12:21 +0200
User-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Thunderbird/78.10.0

Hello Axel

Am 24.04.2021 um 12:54 schrieb Axel Braun:
Hello Edgar,

looks like you had a hard time....

Yes 😉

you need to use the right user, who has a role in postgres. This is either
the user postgres, or the user tryton, see:
Now I changed first to user root (su root), then cd /tmp, then su
postgres, then "createdb health38". No error so far.
Yes, that works, but the database has the owner 'postgres' now.
As it is empty you can savely run
dropdb health38
and afterwards
createdb health38 --encoding='UTF-8' --owner=tryton
Ok, it worked

As described in

you need to tell trytond-admin where the configuration file is (as long as you 
have not set it in the shell environment, see Luis' mail from last days)

So, a proper call would be
su tryton -s /bin/bash
trytond-admin -c /etc/tryton/trytond.conf --all -d health38 -v
(the -v is not required, but gives you some entertainment while the database 
is initialized)
Worked so far: as tryton@GNUHealth-Raspi4 I created the database health38 with email: and password: gnusolidario
Searching for health38* in trytond+subdirectories => no files

Searching for ghdemo38* (that is the database which connects at
localhost) in root+subdirectories, also hidden files => no files

Any ideas? Where can I find the database file itself?
somehwere under /var/lib/pgsql - the standard path of a postgres database (but 
you dont really want do do anything in there)

At /var/lib/pgsql/data/base there are 5 folders like 1, 14049m 14050, 17623 and 27827, all with some files named as numbers. One empty folder is named as pgsql_tmp. With search from /var/lib/ +subdirectories for health38 there is no file. I would be interested in where is the database itself. Because the program does not find it too.

But back to the main problem with the translation:

Logging in again as test and starting the GH client with health38:

worked, starting with "Module configuration" - OK and Configure Users - OK: Name: admin, password gnusolidario, Preferences: Language: only English there! access permissions: only Administration there

again module configuration: click on the line (e.g. account), then the icon gearwheels, Mark for Activation: I marked all Modules (ir and res have already been activated). Then: Perform Pending activation/Upgrade, Start Upgrade (apprx 2 and 1/2 hours) Then: Configure company. Then: Administration Users/Users Preferences: only English!

A look into ...modules/health/locale: 23 languages there. Go to administration/localizations/languages: make translatable: en, de, fr, es Then: synchronize translations: German: Update 2 1/2 hours

logout, login, admin: preferences to German (also Spanish, French there), new login

nevertheless there is no German, except with settings/preferences =>  window with "Einstellung/Benutzereinstellung bearbeiten"

Same with new Party: "Suche Occupation", but only english entries, but with "Abbrechen, Suchen, Neu" ...

So I tried an update like described in as postgres@GNUHealth-Raspi4:

trytond-admin --all --database=health38

OSError: Database "health38.sqlite" doesn't exist!

In fact it seems to be too complicated for me ...

All the best



reply via email to

[Prev in Thread] Current Thread [Next in Thread]