[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gwl-devel] [Bug?] Cannot use Guix Workflow Language on Guix System

From: pelzflorian (Florian Pelz)
Subject: [gwl-devel] [Bug?] Cannot use Guix Workflow Language on Guix System
Date: Wed, 3 Jul 2019 15:25:04 +0200
User-agent: NeoMutt/20180716

How can I use the Guix Workflow Language on Guix System?  I tried
`guix package -i gwl` as described on
<> (the website appears to be
down), but the guix process and guix workflow commands do not become
available.  Apparently guix/ui.scm

  (define directory
    (and=> (search-path %load-path "guix.scm")
           (compose (cut string-append <> "/guix/scripts")

can only use the first scripts directory it finds and therefore never
uses the scripts from the gwl package.

On Debian I had written a Guix workflow to deploy a not-yet-public
Haunt website to a shared hosting provider and tried to use it on Guix
now.  (I hope that is a legitimate use case; I used gwl because I can
specify package inputs.)

I hope this is the right mailing list.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]