[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: State of core-updates

From: Kaelyn
Subject: Re: State of core-updates
Date: Sat, 18 Mar 2023 16:36:26 +0000

------- Original Message -------
On Saturday, March 18th, 2023 at 8:56 AM, Andreas Enge <> wrote:

> Hello,
> Am Fri, Mar 17, 2023 at 08:43:13PM +0000 schrieb Kaelyn:
> > I'm at least a little in favor of that, as the commit message for 
> > cc56be2f3858487cf1d8acfb345942f0784221ee is mis-formatted (it doesn't have 
> > the first 'gnu: ' prefixed summary line, and so git log --oneline doesn't 
> > format it right).
> sorry for that, I did go over the commit message, but overlooked this part.
> > I just quickly formatted and sent a v2 patch using "git format-patch 
> > --attach" and "git send-email" to try to get something at 
> > that will work properly with "git am". 
> > (I'm still puzzled at what happened with the first one, as downloading the 
> > whole message and applying it with "git am" also fails for me.)
> It still does not - there is no first line for the commit message
> (the "gnu: ...").
> When I try to "git am the-message-in-mbox-format", I get:
> fatal: Dirty index: cannot apply patches (dirty: gnu/ 
> gnu/packages/gnome.scm gnu/packages/patches/glib-networking-32-bit-time.patch)
> When I just try to apply "git am 
> v2-0001-gnu-glib-networking-Fix-32-bit-builds.patch":
> Patch format detection failed.
> (which is normal, it does not have the commit message, but starts with
> "diff").
> I may have made an error, but it is suspicious that QA apparently also did
> not manage to extract a git commit (there is no corresponding branch in
> guix-patches).
> Concerning "git send-email", I recently tried it and followed the advice at
> It does not involve a "git format-patch" step.

I'm at a complete loss as to why the patch won't apply properly. I originally 
sent it using "git send-email" (following the manual instructions, which I also 
recently double-checked trying to figure out the problem) as I have done with 
almost all of the other patches I've submitted. The v2 patch was made with the 
addition of "--attachment" to see if the different format transferred better, 
but no luck there. is another patch I sent a 
couple days prior to; I can download 62137 
through the web interface and apply it with git "am", but for either in 62209 I 
encounter the same errors as you.

The original commit message as shown by "git log" is:

commit 1ad88ac769189d36139fbfd3ceb562fbe3a1fed5 (core-updates)
Author: Kaelyn Takata <>
Date:   Wed Mar 15 10:22:25 2023 -0700

    gnu: glib-networking: Fix 32-bit builds.
    * gnu/packages/gnome.scm (glib-networking): Remove obsolete patch.
    * gnu/packages/patches/glib-networking-32-bit-time.patch: Remove patch.
    * gnu/local: Remove it.

I've attached the original patch as generated by "git format-patch core-updates^..core-updates" since the mumi version 
doesn't want to cooperate. I also locally tested that the attached patch worked 
with "git am" locally.


> Andreas

Attachment: 0001-gnu-glib-networking-Fix-32-bit-builds.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]