[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[guile-reader-devel] Guile Reader Fails to build

From: Brad Collins
Subject: [guile-reader-devel] Guile Reader Fails to build
Date: Sat, 29 Jun 2013 12:54:43 +0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux)

I had tried this and failed on an older install of Fedora a
year ago.  But now that I have a nice clean install of
Debian Wheezy, I've tried yet again to build guile-reader.

Make fails for guile-reader with the following error.

ERROR: In procedure sort:
ERROR: In procedure list-copy: Wrong type argument in position 1: (whitespace 
vector string srfi62-sexp-comment srfi-4 srfi30-block-comment 
square-bracket-sexp skribe-exp sexp semicolon-comment scsh-block-comment 
r6rs-symbol-upper-case r6rs-symbol-misc-chars r6rs-symbol-lower-case 
r6rs-number r5rs-upper-case-number r5rs-lower-case-symbol-upper-case 
r5rs-lower-case-symbol-misc-chars r5rs-lower-case-symbol-lower-case 
r5rs-lower-case-number quote-quasiquote-unquote number+radix keyword 
guile-symbol-upper-case guile-symbol-misc-chars guile-symbol-lower-case 
guile-number guile-extended-symbol guile-bit-vector curly-brace-sexp character 
brace-free-symbol-upper-case brace-free-symbol-misc-chars 
brace-free-symbol-lower-case brace-free-number boolean-srfi-4 boolean . #t)
make[2]: *** [token-reader-doc.texi] Error 1
make[2]: Leaving directory `/home/deerpig/downloads/guile-reader-0.5/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/deerpig/downloads/guile-reader-0.5'
make: *** [all] Error 2

Tried both 0.5 and 0.6.

Any ideas what could be going wrong?



Brad Collins <address@hidden>
skype|twitter|wave: deerpig

reply via email to

[Prev in Thread] Current Thread [Next in Thread]