[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] pvgrub2 is merged

From: Fabio Fantoni
Subject: Re: [Xen-devel] pvgrub2 is merged
Date: Tue, 03 Dec 2013 17:16:59 +0100
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.1.1

Il 03/12/2013 16:33, Vladimir 'φ-coder/phcoder' Serbinenko ha scritto:
On 03.12.2013 15:00, Fabio Fantoni wrote:
Il 03/12/2013 12:29, Vladimir 'φ-coder/phcoder' Serbinenko ha scritto:
On 03.12.2013 12:22, Fabio Fantoni wrote:
Il 03/12/2013 11:33, Vladimir 'φ-coder/phcoder' Serbinenko ha scritto:
On 03.12.2013 11:31, Fabio Fantoni wrote:
If you need more tests/informations tell me and I'll post them.
I've already asked you for exact kernel that I can download (and SHA512
to check it's the same one) and got only vague response

Thanks for reply.
The actual kernel used is from this package:

I already checked kernel's files integrity with md5 (using the debian
package's md5sums file and is correct).
Same domU with pygrub with manual and minimal grub.cfg configuration and
it boots correctly, but with pvgrub2 and grub.cfg created automatically
(see attachment of previous mail) it doesn't boot.

With HEAD:
address@hidden:12:21:06:~/compile/bt/x86_64-xen$ ar x
address@hidden:12:23:29:~/compile/bt/x86_64-xen$ tar --xz -xf data.tar.xz
address@hidden:12:28:36:~/compile/bt/x86_64-xen$ sha512sum

address@hidden:12:23:38:~/compile/bt/x86_64-xen$ ./grub-mkstandalone
--grub-mkimage=./grub-mkimage -o grub.xen -O x86_64-xen -d grub-core/

                               GNU GRUB  version 2.00

     Minimal BASH-like line editing is supported. For the first word, TAB
     lists possible command completions. Anywhere else TAB lists possible
     device or file completions.

grub> insmod xzio
grub> linux /boot/vmlinuz-3.11-2-amd64
grub> boot
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Initializing cgroup subsys cpuacct

I've uploaded my grub.xen to

Thanks for any reply.

Thanks for your reply.
I tried with your build and gave me:

Caricamento Linux 3.11-2-amd64...
errore: not xen image.
Caricamento ramdisk iniziale...
errore: ? necessario caricare il kernel prima.

I also rebuilt pvgrub2 from clean directory, full logs of configure,
make and xl create on attachment.
Also in this case domU destroys on kernel and initrd loading.
I not understand what are my errors and/or forgetfulness.

$ sha512sum /boot/vmlinuz-3.11-2-amd64

sha512sum /mnt/tmp/boot/vmlinuz-3.11-2-amd64
002bc39cfc0191614ec380a44993d20691e1dc8791a8c6f3a163777ef6fb733243d3da48760b2eedfc3ab9b8bd7b8fe2d473cdd3a91eb3d855eb4f3db9f7b6df /mnt/tmp/boot/vmlinuz-3.11-2-amd64

Did you try with kernel embed in GRUB?

I tried with ./grub-mkstandalone --grub-mkimage=./grub-mkimage -o pvgrub2.xen -O x86_64-xen -d grub-core/ /mnt/tmp/boot/vmlinuz-3.11-2-amd64
Probably I did something wrong or missed about this test.
On xl create it arrives to grub console, so I tried to set root and include the grub.cfg of domU but gave nothing, only new console line.
Can you give me more details to do a complete and correct test?

Did you try root/linux/initrd/boot sequence manually?

I presume you mean to do insmod, set root and all other command manually without using grub.cfg, could you confirm that or give me an exact howto?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]