grub-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Improve support for genkernel in 10_linux


From: Mike Gilbert
Subject: Re: Improve support for genkernel in 10_linux
Date: Wed, 11 Apr 2012 11:52:53 -0400

2012/4/11 Vladimir 'φ-coder/phcoder' Serbinenko <address@hidden>:
> On 11.04.2012 04:56, Mike Gilbert wrote:
>> On 04/07/2012 05:54 PM, Mike Gilbert wrote:
>>> Secondly, genkernel looks for the "real_root" kernel command line option
>>> to determine the root filesystem. This is a holdover from the days when
>>> we used true initrd images and we needed to use root=/dev/ram0.
>>>
>> It was brought to my attention that genkernel's initramfs code will in
>> fact utilize "root" if "real_root" is unset. This part of my previous
>> patch is therefore pointless.
>>
>> I have attached a revised patch containing only the changes necessary to
>> detect a genkernel initramfs image.
>>
> pushd/popd isn't POSIX so we can't use it in our scripts. Also I don't
> feel like glob expansion is the right thing to use here. Why not infer
> the architecture from uname ?

That should also work. Here's the logic that genkernel uses to populate ARCH:

ARCH=`uname -m`
case "${ARCH}" in
        i?86)
                ARCH="x86"
                ;;
        mips|mips64)
                ARCH="mips"
                ;;
        arm*)
                ARCH=arm
                ;;
        *)
                ;;
esac

I'm thinking it would be a good idea to rename ARCH to something like
GENKERNEL_ARCH. We should also let the user override this in
/etc/default/grub.

Does that sound ok?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]