[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub-mount (ubuntu) hangs with hfs+ partition

From: Vladimir 'φ-coder/phcoder' Serbinenko
Subject: Re: grub-mount (ubuntu) hangs with hfs+ partition
Date: Fri, 24 Feb 2012 11:34:42 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20120216 Icedove/8.0

On 23.02.2012 21:46, Kees Bakker wrote:

In Ubuntu (and Debian I guess) there is a grub-mount command.
It's added to grub with branch_fuse.patch, and in that file it mentions

I have a MacPro system with Ubuntu installed and some HFS+
partitions. Everytime I do a kernel update (and update-grub)
it hangs when a grub-mount command is used on one of the HFS+

The grub-mount command does not hang on all my HFS+ partitions.
But the fact that it hangs on one of them makes it very annoying.

I've tried to debug this problem, but I am not making any progress.
The program hangs in a while(1) loop at line 657 in grub-core/fs/hfsplus.c

there is no loop at this location in the latest trunk. Could you use this please? Also what is the value of currnode on every loop iteration?
BTW. I've also tried to contact Macro Gerards (the contributor of the HFS+
code), but I didn't get a reply from him.

Vladimir 'φ-coder/phcoder' Serbinenko

reply via email to

[Prev in Thread] Current Thread [Next in Thread]