[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub-mount (ubuntu) hangs with hfs+ partition

From: Kees Bakker
Subject: grub-mount (ubuntu) hangs with hfs+ partition
Date: Thu, 23 Feb 2012 21:46:37 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.2) Gecko/20120216 Thunderbird/10.0.2


In Ubuntu (and Debian I guess) there is a grub-mount command.
It's added to grub with branch_fuse.patch, and in that file it mentions

I have a MacPro system with Ubuntu installed and some HFS+
partitions. Everytime I do a kernel update (and update-grub)
it hangs when a grub-mount command is used on one of the HFS+

The grub-mount command does not hang on all my HFS+ partitions.
But the fact that it hangs on one of them makes it very annoying.

I've tried to debug this problem, but I am not making any progress.
The program hangs in a while(1) loop at line 657 in grub-core/fs/hfsplus.c

BTW. I've also tried to contact Macro Gerards (the contributor of the HFS+
code), but I didn't get a reply from him.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]