[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: UFS (FFS) support seems broken in grub2

From: Marco Gerards
Subject: Re: UFS (FFS) support seems broken in grub2
Date: Thu, 24 Jan 2008 19:16:06 +0100
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/21.4 (gnu/linux)

walt <address@hidden> writes:

> Marco Gerards wrote:
>> walt<address@hidden>  writes:
> ...
>>> I recompiled my NetBSD kernel with the MULTIBOOT option enabled, but
>>> I still get a 'magic broken' error when doing 'multiboot /netbsd'.
>> Can it be loaded from GRUB Legacy using its multiboot capabilities?
> Yes!

The error cannot be found in the sourcecode.  Can you provide the
*exact* error?  Providing a kernel might help as well.

>> Do you want to work on a loader for BSD?  That would be the ideal
>> solution and a nice opportunity for you to learn :-)
> Sure, but don't expect very much :o)  We know that grub legacy can
> boot NetBSD, so maybe I can get grub2 to do the same.  Debugging
> a free-standing program like grub is something I've never tried.
> How would you approach the problem if you were going to do it
> yourself?

Read how the loader should work (*BSD documents), get a test kernel,
write a loader and see if it works.  Possibly on qemu, dprintf helps a
lot for debugging.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]