[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Terminal problem? man formatting problem?

From: Oliver Corff
Subject: Re: Terminal problem? man formatting problem?
Date: Mon, 24 Apr 2023 04:01:02 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.5.0

.. continued...

and then I tried, please forgive me, groffer.

I put the manpage file into my working directory and called

$ groffer -man roff.7

And again! This time the URL is rendered with the closing angle bracket
no matter what the URL looks like.

I also tried

$ groff -man -Tpdf roff.7 > roff.pdf

and noticed that okular recognizes the URL, but includes the closing
angle bracket (inspect with right mouse click).

In evince, there are white boxes for the angle brackets, but the URL
also includes those.

Best regards,


PS: I am aware that groffer will be phased out with 1.23.0.

On 24/04/2023 01:40, G. Branden Robinson wrote:
Hi Oliver,

At 2023-04-23T12:23:06+0200, Oliver Corff wrote:
I came across a minor case of misbehaviour when trying to open html
links in man pages.

$ man 7 roff

has a section "SEE ALSO" with a number of links to Internet sites.

The first link under "History of Unix Manpages"
⟨⟩ is ready for opening in the
browser once the mouse hovers over it but cannot be opened (404 file not
found) because the closing parenthesis ")" erroneously makes its way
into the link. See also the automated highlighting (on my terminal via
underlining). The underlined region includes the closing parenthesis
(but not the opening parenthesis).

However, the next link ( is activated correctly.

It seems to be that URLs ending in top-level domains are recognized
correctly whereas URS with a page element (.../history.html in the first
example) are not recognized correctly.

Is this an issue of the terminal (I use lxterminal 0.4.0) of of the
formatting process chain?
It can be.

The manpage source code is structurally identical in both cases:

.\" on-screen URL highlighting includes closing parenthesis, Ctrl+Left
Click produces wrong URL (closing with ")")
.UR http://\\:history.html

.\" on-screen URL highlighting does not include closing parenthesis,
Ctrl+Left Click produces correct URL
.UR http://\
That these hyperlink differently (with respect to trailing punctuation,
apart from the obvious difference in URL content) suggests a problem
with the terminal emulator...

PS: This machine runs groff 1.22.4,
...and that clinches it.  groff 1.22.4 did not attempt to tell the
terminal emulator about hyperlinks; the emulator is inferring them, and
getting it wrong.  (Not a surprise--it is an AI-hard problem to guess

please forgive me if this is already fixed in the upcoming 1.23.0
I _hope_ that it is avoided, and that lxterminal does not try to
pattern-match URLs in the terminal window when the character cells it
would auto-hyperlink are already covered by an active OSC 8 escape
sequence, but I can't promise that any given terminal emulator isn't

This bug might be worth reporting to the lxterminal developers for the
sake of people not yet using groff 1.23.0.  There'll be a few, since we
haven't yet officially released.


Dr. Oliver Corff
Wittelsbacherstr. 5A
10707 Berlin
Tel.: +49-30-85727260

reply via email to

[Prev in Thread] Current Thread [Next in Thread]