[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [platform-testers] groff 1.23.0.rc3 with non-GNU make

From: G. Branden Robinson
Subject: Re: [platform-testers] groff 1.23.0.rc3 with non-GNU make
Date: Mon, 6 Mar 2023 14:00:02 -0600

At 2023-03-06T00:31:18+0100, Bruno Haible wrote:
> On FreeBSD, NetBSD, and AIX, with the platform's 'make' program (which
> is good enough for building many GNU packages, even as a VPATH build),
> I get this build failure:
> $ make
> ...
>   GEN      font/devpdf/DESC
>   GEN      font/devpdf/Foundry
> make: don't know how to make ./shdeps.sed. Stop
> The reason is that the Makefile contains a rule for 'shdeps.sed',
> however, the targets 'chem', 'glilypond', 'gperl' etc. depend
> on $(SH_DEPS_SED_SCRIPT), which expands to './shdeps.sed'.
> Changing arch/misc/
> shdeps.sed: $(top_srcdir)/$(arch_shdeps_sh)
> ->
> ./shdeps.sed: $(top_srcdir)/$(arch_shdeps_sh)
> fixes the problem.

Thanks, Bruno--I've applied this.

But wouldn't it be better to just name the target $(SH_DEPS_SED_SCRIPT)
in the first place?

It's defined in so it seems like it should work.$(top_builddir)/shdeps.sed

I tried this and did not run into problems[1].  On my Debian bullseye
daily development system, I initially tested with GNU Make, and then
with `bmake` (NetBSD make 20200710-14).

Will advise if I run into problems on the other build hosts I can use,
and in each case if I do, will see first if reverting to your explicit
file specification solves them.


[1] Except of my own causing, when I switched "make"s without
    re-"configure"ing.  Rookie mistake.

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]