[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Groff] groff 1.22.3 not building on Fedora 22

From: Ingo Schwarze
Subject: Re: [Groff] groff 1.22.3 not building on Fedora 22
Date: Tue, 11 Nov 2014 20:51:43 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

Hi Werner and Jan,

Werner LEMBERG wrote on Tue, Nov 11, 2014 at 08:18:13PM +0100:
> Jan Chaloupka wrote:

>> I was trying to update groff to 1.22.3 [1].
>> But Makefile is failing me :)
>> There is the following error:
>> make[2]: *** No rule to make target
>> '/builddir/build/BUILD/groff-1.22.3/arch/misc/shdeps.sed', needed by
>> 'gropdf'.  Stop
>> I have spent some time trying to figure out what is wrong but so far
>> with negative result. Can you help me with that? I believe there is
>> just something missing.

Ouch!  I'm forgetful, lazy  -  and very sorry.

I already solved this for OpenBSD and *wanted* to report it here,
but completely forgot to.

This is not OS dependent.
It's a typical case of a missing dependency rule
that bites you in parallel builds.
Here is the patch to fix it:

Also, i'm sorry for missing this in my testing before release.
The problem was first reported by Christian Weisgerber and Nigel Taylor
shortly after release, and i fixed it when i got those two reports.


>> [1]

reply via email to

[Prev in Thread] Current Thread [Next in Thread]