[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Groff] [Groff-commit] groff ChangeLog INSTALL.gen Makef

From: Bernd Warken
Subject: Re: [Groff] [Groff-commit] groff ChangeLog INSTALL.gen Makefil...
Date: Tue, 16 Apr 2013 21:22:19 +0200 (CEST)

> Von: "Werner LEMBERG" <address@hidden>
> this is still not OK.

I tried another run.  I hope it's now ok.

> > RCS file: /cvsroot/groff/groff/INSTALL.gen,v
> > retrieving revision 1.7
> > retrieving revision 1.8
> > diff -u -b -r1.7 -r1.8
> *Never* change this file manually!  It is a generic one provided from
> GNU (normally called `INSTALL').  Please restore it (or get the newest
> version from the `gnulib' or `automake' git repository).

Yeah!  I got an actual version from `automake'  I added a line on top
that this file should not be changed.

> > RCS file: /cvsroot/groff/groff/aclocal.m4,v
> > [...]
> > +# 
> > ===========================================================================
> > +#
> > +# 
> > ===========================================================================
> > [...]
> As told earlier, such stuff shouldn't be in this file; there should
> only be lines of the form
>   m4_include([m4/foo.m4])
> The reason for this problem is that you are using the macro
> AX_PROG_PERL_VERSION (in `groff.m4') without adding the file
> `ax_prog_perl_version.m4' to the repository.

That's right.  I added the file `ax_prog_perl_version.m4' to the `m4' directory
and prepared the Makefiles to get it work.

> > RCS file: INSTALL.autotools
> I think this is the wrong file name; I would rather call it
> `INSTALL.CVS'.  And it makes only sense to have it in case the
> `configure' script and all other generated files are removed from the
> CVS.

I move `INSTALL.autotools' to `INSTALL.CVS'.

> Two other minor issues:
> . file `groff.m4':
>   @@ -134,6 +148,7 @@
>         AC_MSG_WARN([missing program$plural:
>      The program$plural
>   +
>         $missing
>      cannot be found in the PATH.
>      Consequently, groff's HTML backend (grohtml) will not work properly;
>   Why the additional newline?  If you do so, I would rather expect to
>   have another one after the `$missing' line also.

I do not know where the empty line came from.  I just rempoved it.

> . file `':
>   All variables which are defined globally should be added to the
>   `MDEFINES' definition.  You haven't done so for `PERLVERSION'.

Thanks, done I hope.

I got a curious error messaqge from the grog Makefile.sub.  In the ionternet
it is said that `GNU make' works only correctly when all lines start with a
`tab' instead of spaces.  I corrected this and the compilation worked without

Bernd Warken

PS: I do not have time to proceed work until 24 April 2013.  If there is still
some misbehavior someone else should do it.  The `grog' in the CVS works, but
it's not 100% ok.  Please do not fix it because I created a new version which
does not work so far.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]