[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Groff] groff man page blank

From: Zoong PHAM
Subject: Re: [Groff] groff man page blank
Date: Thu, 14 Nov 2002 11:41:29 +1100
User-agent: Mutt/1.4i

Thanks Tadziu and Werner for your help,

On Wed, Nov 13, 2002 at 08:20:19PM +0100, Tadziu Hoffmann wrote:
> I "solved" the problem by simply providing preformatted
> manual pages for all groff-related stuff:
> ----------------------------------------------------------------
> for file in man/man*/*
> do
>   name=`basename $file`
>   sec=`echo $name | cut -d. -f2`
>   groff -man-old -Tascii $file >/usr/local/man/cat$sec/$name
> done
> ----------------------------------------------------------------
> (We install programs each in their own directories, and
> then simply create symbolic links from /usr/local/bin,
> /usr/local/man/man*, etc. to the files in those installation
> directories.  Then I can call the above routine in the groff
> installation directory and be sure it involves only groff's
> manual pages.)

I tried the above routine in the installation directory.
Now the outputs of "man groff" or "man grops" and others that
groff-1.18.1 installed contain control characters 
like ESC[1m for bold, etc.

I also tried :
/usr/local/groff-1.18.1/bin/gnroff -man-old 
/usr/local/groff-1.18.1/man/man1/groff.1 | less
/usr/local/groff-1.18.1/bin/gnroff -man 
/usr/local/groff-1.18.1/man/man1/groff.1 | less

and have the same control characters problem.

I tried with different terminals like xterm, dtterm, ... but the
problem still there.

How can I fix this?

Zoong PHAM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]