[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Groff] Groff 1.12.1 binary rpms?

From: Werner LEMBERG
Subject: Re: [Groff] Groff 1.12.1 binary rpms?
Date: Sat, 25 Dec 1999 13:06:02 GMT

> Of course. And I'm glad to hear 1.13 is out.

1.14 will soon come -- I just had to fix a fix within :-(  

> I've tried using 1.13 myself. Don't work for me yet.
> - Created a bin directory in my ~.
> - Ran ./configure --prefix=/home/mngovsci/bin

Any reason why you call the subdir `bin'?  Usually, this is reserved
for binary files...

> - Ran make
> - Ran make check
> - Ran make install
> So far all OK. Now...
> How do I run groff-test?

Change to the directory where groff's configure script resides, then
do, for example

  zcat /usr/man/man1/man.1.gz | ./test-groff -t -mandoc -Tlatin1 | less

assuming that the man page of the program `man' is compressed, and
your terminal window supports latin1.  I hope you are familiar with
piping :-)

> How do I run groff?

For man pages you don't do it directly; `man' will call groff by
itself (e.g. for the above example, `man man' will do the trick).
Please check the documentation of `man' whether it will search `groff'
in $PATH or whether it uses a hard-wired path to groff.

> groff-test wants to be run from the "build directory".
> I tried the obvious already. What's the right way?
> groff:
> groff -v
> -> GNU troff version 1.11a-7 (debian)

Apparently you haven't modified your $PATH environment variable -- you
must add `/home/mngovsci/bin/bin' *at the beginning*.  The shell will
traverse along $PATH, and the first hit wins.

> /home/mngovsci/bin/bin/groff -v
> -> Exact same thing.

This can't be possible!  Something must be wrong...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]