[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Can't get gpsfake/gpsd to work together

From: Steven Wawryk
Subject: Can't get gpsfake/gpsd to work together
Date: Fri, 13 May 2022 11:22:45 +0000


I'm developing an application that reads GPS data from gpsd servers.  My 
development machine has no GPS, so I want to use gpsfake for testing.  I 
thought it was supposed to work out of the box, but I
just can't get it to work.  I also can't find any similar issue in the FAQ, the 
troubleshooting section, or with google/duckduckgo - nothing I've found has 
been helpful.

The versions of gpsd, gpsfake and gpslib are 3.20, as it comes standard with 
the ubuntu 20.04 repos, but I would have thought that should still all work 

An example command line with resulting output is:

$ gpsfake -v -l -P 2948 -c 1 output.nmea
Processing output.nmea
gpsd:ERROR: can't bind to local socket /tmp/gpsfake-3691836.sock
gpsd:ERROR: control socket create failed, netlib error -1
Traceback (most recent call last):
  File "/usr/bin/gpsfake", line 319, in <module>
  File "/usr/lib/python3/dist-packages/gps/", line 737, in run
    raise TestSessionError("daemon died")

I've tried all kinds of other command options including -o to pass on various 
options to gpsd.  To rule out interference from the gpsd daemon I've tried it 
with and without:

$ sudo service gpsd stop
Warning: Stopping gpsd.service, but it can still be activated by:
$ systemctl stop gpsd.socket gpsd.service

No matter what I do the outcome stubbornly remains identical.

Can anyone help?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]