[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cross compile gpsd-3.20.1~dev for arm with buildroot

From: Gary E. Miller
Subject: Re: Cross compile gpsd-3.20.1~dev for arm with buildroot
Date: Tue, 16 Jun 2020 12:34:56 -0700

Yo Florian!

On Tue, 16 Jun 2020 17:08:35 +0200
Florian Kiera <> wrote:

> Doesn't use LD anymore, so that works now! Thank you for fixing it!

Thank you for your patience.  It was a weird one.

> The other issue regarding libtools; I guess it is coming from 
> python3/python2 conflicts...

Nope.  Your log shows scons built and installed everything fine.

From your log.  Here is the last file installed:

> Install file: "packaging/X11/gpsd-logo.png" as 
> "/home/asterix/buildroot/buildroot-2019.02.8.1/output/host/arm-buildroot-linux-uclibcgnueabihf/sysroot/usr/share/gpsd/icons/gpsd-logo.png"

Here is sconss saying it is done building/installing:

> scons: done building targets.

Thsn, dunno where this comes from:

> >>> gpsd 3.20.1~dev Fixing libtool files
> for la in $(find 
> /home/asterix/buildroot/buildroot-2019.02.8.1/output/host/arm-buildroot-linux-uclibcgnueabihf/sysroot/usr/lib*
>  -name "*.la"); do \
>       cp -a "${la}" "${la}.fixed" && \

It is NOT part of gpsd:

gpsd # fgrep linktool * -r
gpsd # 

No libtool anywhere.

It is also NOT part of scons:

gpsd # fgrep libtool /usr/lib64/python3.6/site-packages/SCons/ -R
gpsd # 

No libtool anywhere.

I'm still looking at it, may take a while for enlightenment.

> I will try to remove python2 entirely
> from our buildroot and than just stick to python3.

Does not matter.  scons uses the python that it started with.  Python
slotting works pretty well on all distros.  And your scons worked
seemingly perfectly for you.  You turned off all use of Python except
for scons.

> Either way it happens to multiple packages, since I am messing around
> with python3, so gpsd might be innocent here...

You see this on packages that are not gpsd?  Looks to me like a bulidroot
problem.  A quick google shows several libtool issues with builtroot, but
I do not understand them.

Also from the build log:

    Applying 0001-SConstruct-do-not-force-O2-by-default.patch using patch: 

You turn off -O2 several places, then turn it back on...

> Also the if you wanna know what exactly is beeing done. (Its
> the default one from the buildroot-2020.05 just with an edited
> version)

Ugh.  I guess someone loves it somewhere...

gpsd does not support anything earlier than C99, so if this actually worked
if would break things:

    GPSD_CFLAGS += -std=gnu++98
    GPSD_CXXFLAGS += -std=gnu++98

Fixed port speed is gone:


Other options are also gone.  You should recheck you mk file against
current bulid options.

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703  Tel:+1 541 382 8588

            Veritas liberabit vos. -- Quid est veritas?
    "If you can't measure it, you can't improve it." - Lord Kelvin

Attachment: pgpCEjGMdXoAU.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]