[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gpsd + ubx

From: Florian Kiera
Subject: Re: gpsd + ubx
Date: Wed, 3 Jun 2020 11:27:38 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.8.1

Hey Gary!

Am 02.06.20 um 20:05 schrieb Gary E. Miller:
Yo Florian!

On Tue, 2 Jun 2020 10:30:45 +0200
Florian Kiera <> wrote:

This mail was supposed to be send on the 28th of May, somehow it was
not send properly. Maybe due to the size of the attachments... Hope
decoding logs.tar.gz is fine
I assume they are the same size and working now?

Are these still from May 28?  A lot of changes since then.

The issues I had with gpsd might be solved with the changes to
What changes?  When?  Where?

Can you please repeat with git head?

I warned people this is new code.
Latest git head doesn't work for me.
"Latest" not useful after 5 days...

Whenever I run "gpsd -n
/dev/ttyACM0 -N -D 5" (the USB definition is needed to make gpsd not
working) the gpsd starts things up and after getting a message from
the ubx device (always the same) gpsd freezes and cannot be stopped
except through "sudo kill -9 id".
You realize you are missing "-n"?

Ugh, someone changed the ttyACM0 code recently, I guess they forgot to test it.

commit a18044dd88b8b9d0b2cada261913ca03433af5f3
Author: Joachim Kross <>
Date:   Wed May 20 18:11:23 2020 +0200

But you tested gpsd after that?

Log of this: gpsd_crash.txt: will run it with D 10 there, gpspipe and
gpsmon will be empty too         attachment
I see no crash in gpsd_crash.txt  look normal.

Maybe one of the driver*.c that were changed causes the loop?
Loop !- crash.  Which is it?

You realize without "-n" it is normal for gosd to do nothing there?

Always best to submit patches as MRs.
Hope I did it right, never worked with github/gitlab that way. It was
an attachment of the mail where I wrote "ubxtool.patch: contains the
additions I made" tho.
My long term memory is nil.  Please resubmit anything 5 day old.  Unless
I already merged something.

Latest gpsd gitlab head works fine again. :) I used -n tho. However sorry for giving the outdated logs, here are the current (used latest git head 3rd June 2020 11am CET).

I compromised them to the archive logs.tar.gz to prevent too huge file sizes again: logs.tar.gz: file I run on the base (contains the settings I make and the pull requests for config and status)
-base_status.txt: status output of
-base_config.txt: config output of file I run on the rover (contains the settings I make and the pull requests for config and status)
-rover_status.txt: status output of
-rover_config.txt: config output of

Regards Florian

Attachment: logs.tar.gz
Description: application/gzip

reply via email to

[Prev in Thread] Current Thread [Next in Thread]