[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Release blockers

From: Steve Bourland
Subject: Re: Release blockers
Date: Thu, 12 Dec 2019 14:19:42 -0600 (CST)
User-agent: Alpine 2.21 (DEB 202 2017-01-01)

Yo Gary!

I'm 99% confident the problem I am running into is on my requirements, but I have been struggling all morning. Downloaded master yesterday afternoon (Central Time), working on building from source on a fresh Ubuntu 18.04.3 install. First run of scons worked and indicated it built everything, but now stuck on scons check with:

/usr/bin/python /home/sbourland/src/gpsd-master/xgps -V
xgps: ERROR Unsupported Gtk version

Looking at the xgps code, I ran the following test in a python (Python 2.7.15+) shell:
import gi
(3, 26, 1)
gi.require_version('Gtk', '3.0')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
File "/usr/lib/python2.7/dist-packages/gi/", line 130, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Gtk not available

If I use a python3 shell (Python 3.6.8) I get the same results.
Trying to help out with some testing, but not going so super well for me, sorry. Have any hints on how to move forward? Wanting to test the week rollover fixes (specifically with my garbage Garmins).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]