[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] Looking for the ubx commands that gpsd send to ublox ze

From: Gary E. Miller
Subject: Re: [gpsd-users] Looking for the ubx commands that gpsd send to ublox zed-f9p on startup
Date: Sat, 13 Apr 2019 17:24:45 -0700

Yo Svenn!

On Sat, 13 Apr 2019 12:28:42 +0200
Svenn Are Bjerkem <address@hidden> wrote:

> following master git branch from savannah I try to get gpsd to talk
> and listen to a zed-f9p on the simplertk2b.

Until 12 Apr, the ZED worked very poorly with gpsd.  Until last week
the ZED worked not at all with gpsd.  Getting better now.

What is "simplertk2b"?

> I use the usb connection
> which shows up as a ttyACMx. The platform is a Lenovo T410 with
> Debian where I wiped the systemd-gpsd. I build with scons and start
> gpsd without installing.
> ./gpsd -n -N -D3 /dev/ttyACM
> Then start ./gpsmon to see what comes out of the gps
> I notice that gpsd has put the f9p into binary mode.

Yes.  Running NMEA on newer u-blox is bad for our mental health.

If you want gpsd to not touch your GPS, then start with the -b
command.  Not recommended except for wizards.

> In binary mode, gpsmon does not show any SV data, just a few rolling
> ubx.

Yeah.  The ZED removed the old messages to get SV data.  Also partly
because gpsd is not setting binary mode properly in the 9 series.
Better to do this for now, after gpsd starts (no -b):
        # ubxtool -d NMEA -P 27
        # ubxtool -e BINARY -P 27

> I then switch to NMEA mode with ./gpsctl -n

Also a bit broken.  u-blox seriously changed things in the 9-series.
Still getting it working in gpsd.

> gpsmon starts showing SV information, *DOP and such.

Yeah, but some important stuff missing...

> Switch back to binary mode with ./gpsctl -b

Also broken, use ubxtool for now.

> Same as before, with very few ubx sentences rolling and no SV info.

u-blox changed how sats, and pvt, get reported...

> Where can I study the configuration being sent from gpsd to f9p on
> startup and on gpsctl -b?

driver_ubx.c in ubx_cfg_prt() and in ubxtool in send_able_binary()
and send_able_nmea().  Undergoing a lot of change now.

There are over 1,200 lines of new code, just in the ubxtool, to support
the new configuration items scheme in the ZED.  This will not be
stable for a while.

> I would like to see if I need to configure
> some other UBX- sentences with u-centre before attaching the f9p to
> linux.

Oh, please, no.  gpsd does not understand any old junk you throw at
it.  Getting the sentence mix just right is hard work.  And then
gpsd will overwrite it.  Unless you use -b, and then you lose a
lot of functionality.  Try to use ubxtool.

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703
        address@hidden  Tel:+1 541 382 8588

            Veritas liberabit vos. -- Quid est veritas?
    "If you can’t measure it, you can’t improve it." - Lord Kelvin

Attachment: pgpR5SUu4LsRi.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]