[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gpsd-users] I do not have 3.18~dev working on my Raspberry Pi 3 B+ (in

From: Paul Theodoropoulos
Subject: [gpsd-users] I do not have 3.18~dev working on my Raspberry Pi 3 B+ (in reply to 'Who has 3.18~dev working on a Raspberry Pi?)
Date: Tue, 24 Jul 2018 12:23:28 -0700
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Thunderbird/60.0

Just subscribed to the list, after seeing the thread '1PPS not working with RPi3 B+ and Stretch'.

I'm having the same/similar issue.

My ntp server is currently running on a copy of gpsd built from repo clone a month ago back on 20jun2018. I didn't save the build dir, but 'strings' shows that it is "release-3.17-58-g70824d3f". This copy runs fine.

However, if I build from the current repo (downloaded yesterday 23jul2019, 'strings' reports "release-3.17-157-g5e95e79c"), my ntp server is non-functional. This new version gives clean and correct cgps output, gpsmon output, ppstest output, ipcs -m output (with correct owner and perms), ...

...but dead silence from ntpshmmon, as Chris Smith reports - only if I run ntpshmmon -v, I get the same "Unit 0 status 1", "Unit 1 status 1", "Unit 2 status 1" etc, extremely rapidly until control-c out of it.

I used the same build options on the 'old' one and the new one -

scons timeservice=yes magic_hat=yes nmea0183=yes fixed_port_speed=115200 fixed_stop_bits=1

I am building on fully updated Raspbian Stretch Lite, on the same hardware (adafruit hat). I tried building it on a bog-fresh (but updated) raspian stretch lite image, identical results.

Let me know if you need more info.

Paul Theodoropoulos

reply via email to

[Prev in Thread] Current Thread [Next in Thread]