[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gpsd-users] Savannah access problem solved

From: Eric S. Raymond
Subject: [gpsd-users] Savannah access problem solved
Date: Wed, 31 Aug 2016 18:56:55 -0400
User-agent: Mutt/1.5.24 (2015-08-30)

My Savannah access problem is solveed. I'm explainming the solution here
because the same problem could mug anyone on their next ssh upgrade.

In Ubuntu 16.04 ssh was upgraded to version OpenSSH_7.2p2.  This changed the
way it negotiated with ssh servers, which I first noticed when it began
objecting to the string "Version 1" in my ssh config.

I have three private keys: DSA, RSA, and ED25519.  The old client
behavior presented RSA by default, and Savannah was fine with that.
The new client behavior is to present ED25519 by default; what it's
probably doing is looking for the strongest key.  I got a clue to this
when Bob Proulx of Savannah reported that this message might be
associated with my login attempt:

userauth_pubkey: unsupported public key algorithm: ssh-ed25519 

This confused Savannah, which doesn't handle that key type.  The fix is
simple. Append these two lines to your ~/.ssh/config:

IdentityFile ~/.ssh/id_rsa
Host *
IdentityFile ~/.ssh/id_rsa

This will force ssh to ship your RSA key to Savannah and its git host box.

You will probably find you need to re-clone the repo before you can push to it.
                <a href="";>Eric S. Raymond</a>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]