[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] Large ntp.conf time1 offset needed with GPSD shared mem

From: Jon Brase
Subject: Re: [gpsd-users] Large ntp.conf time1 offset needed with GPSD shared memory driver
Date: Wed, 17 Aug 2016 18:27:08 -0500
User-agent: Opera Mail/12.16 (Linux)

On Tue, 16 Aug 2016 01:20:31 -0500, Gary E. Miller <address@hidden> wrote:

Yo Jon!

On Tue, 16 Aug 2016 01:07:41 -0500
"Jon Brase" <address@hidden> wrote:

OK, from doing the GPSD side of that I do now seem to have a build of
GPSD that will actually see PPS. I'd tried a previous set of
directions from (written, I think, before esr had worked
with a Pi himself), and the build of GPSD that resulted from those
directions would not see PPS whatever I did.

Send him a complaint!

Well, now that he has a Pi-specific howto,

I will note, however, that trying to build ntpsec from the
stratum-1-microsever-howto results in the build failing with "'28' is
not a valid Refclock ID". But I've got a working ntpd (recompiled
from the Raspbian sources with PPS), so I think I'm good at this

Send me a bug report. I'll ram it down his throat, nicely of course. :-)

Excuse me, I was a bit imprecise, I should actually say that "waf configure" fails with the invalid refclock ID error. My previous statement might have implied that "waf build" was failing.

Anyways, I'm running Raspbian Jessie on a Raspberry Pi A+. A lot of the intial setup (up to the point that the howto directs you to run the clockmaker script) I had already done. My SD card was imaged with the 2016-02-09 Raspbian image rather than the 2016-03-18 image used in the howto.

I first tried running clockmaker, and then when that failed to build ntpsec, went through the ntpsec build instructions manually.

trying to run "./waf configure --refclock=28" manually results in this output:

The associate logfile content is:

I will note that the clockmaker script included a few more refclock IDs than just 28 in the waf configure line, including refclock 1. The configuration errored out on refclock 1 when that was included by clockmaker, so it would seem that the --refclock option is dying on the first refclock ID passed, whatever that ID is.

"waf configure" succeeds if I leave the --refclock option out entirely, resulting in the following output:

Jon Brase

reply via email to

[Prev in Thread] Current Thread [Next in Thread]