[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] heading info ?

From: Eric S. Raymond
Subject: Re: [gpsd-users] heading info ?
Date: Wed, 21 May 2014 05:55:39 -0400
User-agent: Mutt/1.5.21 (2010-09-15)

Niall Parker <address@hidden>:
> Finally found a Garmin tech support person willing to work through
> the details, good news is that I can clearly see the heading output
> from my Oregon 450 ($HCHDG) when connected via USB in spanner mode.

Sorry for the belated reply, I've beenb eyebrow-deep in other projects.
> Steps done so far:
> 1. update to latest release (3.10, was 3.4 on Ubuntu 12.04).
>      * Built from source after installing build-deps
>      * scons check ran nominally without error (saw issue with shared
>        memory invalid but saw in archives this is transient)
> 2. run ./gpsd -D 5 -N -n /dev/ttyUSB0, seems to work, xgps and gpspipe
>    give basic position data
> 3. install to /usr/local etc.
> 4. basic operation (hotplug etc) working
> 5. gpsmon gives live data, recognized Garmin serial binary
> 6. tried gpscat -p /dev/ttyUSB0
>      * noted this doesn't work with gpsd, correct ?


>      * initially got error on startup :
>      * Traceback (most recent call last):
>           File "/usr/local/bin/gpscat", line 15, in <module>
>             BASELEVEL = sniffer.LOG_IO
>        AttributeError: 'module' object has no attribute 'LOG_IO'
> 7. hacked sniffer.LOG_IO to be constant 5
That doesn't replicate here.  Check your PYTHONPATH to see if you might 
loading a stale version of the Python binding.

> 8. tried again ... no data output
> Does gpscat/gpsctl need to do something to convince the gps to start
> spitting out data ?

Not to my knowledge, but Garmins are weird. The fact that you see sentences
when running gpsd -D 5 -N -n /dev/ttyUSB suggests not.  Look at the log from
that run; if it's shipping a ewlevant init string you should be able to see it.
                <a href="";>Eric S. Raymond</a>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]